CVE-2013-2062

NameCVE-2013-2062
DescriptionMultiple integer overflows in X.org libXp 1.0.1 and earlier allow X servers to trigger allocation of insufficient memory and a buffer overflow via vectors related to the (1) XpGetAttributes, (2) XpGetOneAttribute, (3) XpGetPrinterList, and (4) XpQueryScreens functions.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2685-1
NVD severitymedium (attack range: remote)
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libxp (PTS)squeeze (security), squeeze1:1.0.0.xsf1-2+squeeze1fixed
wheezy, wheezy (security)1:1.0.1-2+deb7u1fixed
jessie, sid1:1.0.2-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libxpsource(unstable)1:1.0.1-2+deb7u1medium
libxpsourcesqueeze1:1.0.0.xsf1-2+squeeze1mediumDSA-2685-1
libxpsourcewheezy1:1.0.1-2+deb7u1mediumDSA-2685-1

Search for package or bug name: Reporting problems