CVE-2013-2064

NameCVE-2013-2064
DescriptionInteger overflow in X.org libxcb 1.9 and earlier allows X servers to trigger allocation of insufficient memory and a buffer overflow via vectors related to the read_packet function.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2686-1
NVD severitymedium (attack range: remote)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libxcb (PTS)squeeze, squeeze (security)1.6-1+squeeze1fixed
wheezy (security), wheezy1.8.1-2+deb7u1fixed
stretch, sid, jessie1.10-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libxcbsource(unstable)1.8.1-2+deb7u1medium
libxcbsourcesqueeze1.6-1+squeeze1mediumDSA-2686-1
libxcbsourcewheezy1.8.1-2+deb7u1mediumDSA-2686-1

Search for package or bug name: Reporting problems