CVE-2013-2065

NameCVE-2013-2065
Description(1) DL and (2) Fiddle in Ruby 1.9 before 1.9.3 patchlevel 426, and 2.0 before 2.0.0 patchlevel 195, do not perform taint checking for native functions, which allows context-dependent attackers to bypass intended $SAFE level restrictions.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-235-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ruby1.8 (PTS)wheezy1.8.7.358-7.1+deb7u3fixed
wheezy (security)1.8.7.358-7.1+deb7u4fixed
ruby1.9.1 (PTS)wheezy1.9.3.194-8.1+deb7u5fixed
wheezy (security)1.9.3.194-8.1+deb7u6fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ruby1.8source(unstable)(not affected)
ruby1.9.1source(unstable)1.9.3.448-1low
ruby1.9.1sourcesqueeze1.9.2.0-2+deb6u4mediumDLA-235-1
ruby1.9.1sourcewheezy1.9.3.194-8.1+deb7u1medium

Notes

- ruby1.8 <not-affected> (Only affects 1.9 and 2.x)
http://svn.ruby-lang.org/cgi-bin/viewvc.cgi?view=revision&revision=40732

Search for package or bug name: Reporting problems