CVE-2013-2070

NameCVE-2013-2070
Descriptionhttp/modules/ngx_http_proxy_module.c in nginx 1.1.4 through 1.2.8 and 1.3.0 through 1.4.0, when proxy_pass is used with untrusted HTTP servers, allows remote attackers to cause a denial of service (crash) and obtain sensitive information from worker process memory via a crafted proxy response, a similar vulnerability to CVE-2013-2028.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2721-1
NVD severitymedium (attack range: remote)
Debian Bugs708164
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
nginx (PTS)squeeze, squeeze (security)0.7.67-3+squeeze3fixed
squeeze (lts)0.7.67-3+squeeze4fixed
wheezy, wheezy (security)1.2.1-2.2+wheezy3fixed
jessie1.6.2-5fixed
stretch, sid1.9.3-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
nginxsource(unstable)1.4.1-1medium708164
nginxsourcesqueeze(not affected)
nginxsourcewheezy1.2.1-2.2+wheezy1mediumDSA-2721-1

Notes

[squeeze] - nginx <not-affected> (Vulnerable code not present)

Search for package or bug name: Reporting problems