CVE-2013-2104

NameCVE-2013-2104
Descriptionpython-keystoneclient before 0.2.4, as used in OpenStack Keystone (Folsom), does not properly check expiry for PKI tokens, which allows remote authenticated users to (1) retain use of a token after it has expired, or (2) use a revoked token once it expires.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
keystone (PTS)stretch (security), stretch2:10.0.0-9+deb9u1fixed
buster, buster (security)2:14.2.0-0+deb10u1fixed
bullseye2:18.0.0-3+deb11u1fixed
bookworm, sid2:20.0.0-3fixed
python-keystoneclient (PTS)stretch1:3.2.0-4fixed
buster1:3.17.0-2fixed
bullseye1:4.1.1-2fixed
bookworm, sid1:4.3.0-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
keystonesourcewheezy(not affected)
keystonesource(unstable)(not affected)
python-keystoneclientsourcewheezy(not affected)
python-keystoneclientsource(unstable)1:0.2.5-1

Notes

- keystone <not-affected> (Vulnerable code only in experimental versions of keystone)
[wheezy] - keystone <not-affected> (PKI token support not yet present)
[wheezy] - python-keystoneclient <not-affected> (vulnerable code not present)
Keystone Folsom fix: https://review.openstack.org/#/c/30743/
python-keystoneclient fix: https://review.openstack.org/#/c/30742/
Starting with 2013.1-1 code in keystone/middleware/auth_token.py moved to python-keystoneclient

Search for package or bug name: Reporting problems