CVE-2013-2126

NameCVE-2013-2126
DescriptionMultiple double free vulnerabilities in the LibRaw::unpack function in libraw_cxx.cpp in LibRaw before 0.15.2 allow context-dependent attackers to cause a denial of service (application crash) and possibly execute arbitrary code via a malformed full-color (1) Foveon or (2) sRAW image file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)
Debian Bugs710353, 711316, 711317

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
darktable (PTS)jessie1.4.2-1+deb8u1fixed
stretch2.2.1-3fixed
buster, sid2.4.4-1fixed
libkdcraw (PTS)jessie4:4.14.0-1fixed
stretch4:15.08.0-1.1fixed
libraw (PTS)jessie (security), jessie0.16.0-9+deb8u3fixed
stretch (security), stretch0.17.2-6+deb9u1fixed
buster, sid0.19.0-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
darktablesource(unstable)1.2.1-2unimportant711316
kdegraphicssource(unstable)(unfixed)high
kdegraphicssourcesqueeze(not affected)
libkdcrawsource(unstable)4:4.8.4-2low711317
librawsource(unstable)0.15.3-1low710353
librawsourcesqueeze(not affected)

Notes

[wheezy] - libraw <no-dsa> (Not suitable for code injection, minor issue)
[squeeze] - libraw <not-affected> (Vulnerable code not present)
[wheezy] - libkdcraw <no-dsa> (Not suitable for code injection, minor issue)
Not suitable for code injection, no security impact for an enduser application like Darktable
[squeeze] - kdegraphics <not-affected> (embedded version of kdcraw+libraw too old)
http://www.openwall.com/lists/oss-security/2013/05/28/3
https://github.com/LibRaw/LibRaw/commit/19ffddb0fe1a4ffdb459b797ffcf7f490d28b5a6

Search for package or bug name: Reporting problems