DescriptionBuffer overflow in the exposure correction code in LibRaw before 0.15.1 allows context-dependent attackers to cause a denial of service (crash) and possibly execute arbitrary code via unspecified vectors.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
darktable (PTS)stretch2.2.1-3fixed
bullseye, sid3.0.2-1fixed
libkdcraw (PTS)stretch4:15.08.0-1.1fixed
libraw (PTS)stretch (security), stretch0.17.2-6+deb9u1fixed
bullseye, sid0.19.5-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
darktablesource(unstable)(not affected)
libkdcrawsource(unstable)(not affected)
librawsource(unstable)(not affected)


- libraw <not-affected> (Only affects 0.15, 0.15 was only in experimental)
- libkdcraw <not-affected> (embeds libraw 0.14)
- darktable <not-affected> (embeds libraw 0.14)

Search for package or bug name: Reporting problems