CVE-2013-2132

NameCVE-2013-2132
Descriptionbson/_cbsonmodule.c in the mongo-python-driver (aka. pymongo) before 2.5.2, as used in MongoDB, allows context-dependent attackers to cause a denial of service (NULL pointer dereference and crash) via vectors related to decoding of an "invalid DBRef."
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2705-1
NVD severitymedium (attack range: remote, user-initiated)
Debian Bugs710597
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pymongo (PTS)squeeze1.7-1fixed
wheezy (security), wheezy2.2-4+deb7u1fixed
jessie2.7.2-1fixed
stretch, sid3.0.3-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pymongosource(unstable)2.5.2-1medium710597
pymongosourcesqueeze(not affected)
pymongosourcewheezy2.2-4+deb7u1mediumDSA-2705-1

Notes

[squeeze] - pymongo <not-affected> (bson module not present)
https://jira.mongodb.org/browse/PYTHON-532
https://github.com/mongodb/mongo-python-driver/commit/a060c15ef87e0f0e72974c7c0e57fe811bbd06a2

Search for package or bug name: Reporting problems