CVE-2013-2139

NameCVE-2013-2139
DescriptionBuffer overflow in srtp.c in libsrtp in srtp 1.4.5 and earlier allows remote attackers to cause a denial of service (crash) via vectors related to a length inconsistency in the crypto_policy_set_from_profile_for_rtp and srtp_protect functions.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2840-1
NVD severitylow (attack range: remote)
Debian Bugs711163
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
srtp (PTS)squeeze, squeeze (security)1.4.4~dfsg-6+deb6u1fixed
wheezy, wheezy (security)1.4.4+20100615~dfsg-2+deb7u1fixed
stretch, jessie, sid1.4.5~20130609~dfsg-1.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
srtpsource(unstable)1.4.5~20130609~dfsg-1low711163
srtpsourcesqueeze1.4.4~dfsg-6+deb6u1lowDSA-2840-1
srtpsourcewheezy1.4.4+20100615~dfsg-2+deb7u1lowDSA-2840-1

Search for package or bug name: Reporting problems