CVE-2013-2155

NameCVE-2013-2155
DescriptionApache Santuario XML Security for C++ (aka xml-security-c) before 1.7.1 does not properly validate length values, which allows remote attackers to cause a denial of service or bypass the CVE-2009-0217 protection mechanism and spoof a signature via crafted length values to the (1) compareBase64StringToRaw, (2) DSIGAlgorithmHandlerDefault, or (3) DSIGAlgorithmHandlerDefault::verify functions.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2710-1
NVD severitymedium (attack range: remote)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
xml-security-c (PTS)squeeze, squeeze (security)1.5.1-3+squeeze3fixed
wheezy, wheezy (security)1.6.1-5+deb7u2fixed
stretch, sid, jessie1.7.2-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
xml-security-csource(unstable)1.6.1-6medium
xml-security-csourcesqueeze1.5.1-3+squeeze2mediumDSA-2710-1
xml-security-csourcewheezy1.6.1-5+deb7u1mediumDSA-2710-1

Search for package or bug name: Reporting problems