CVE-2013-2168

NameCVE-2013-2168
DescriptionThe _dbus_printf_string_upper_bound function in dbus/dbus-sysdeps-unix.c in D-Bus (aka DBus) 1.4.x before 1.4.26, 1.6.x before 1.6.12, and 1.7.x before 1.7.4 allows local users to cause a denial of service (service crash) via a crafted message.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2707-1
NVD severitylow (attack range: local)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
dbus (PTS)squeeze1.2.24-4+squeeze2fixed
squeeze (lts)1.2.24-4+squeeze3fixed
wheezy1.6.8-1+deb7u5fixed
wheezy (security)1.6.8-1+deb7u6fixed
jessie1.8.18-0+deb8u1fixed
stretch, sid1.8.18-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
dbussource(unstable)1.6.12-1low
dbussourcesqueeze(not affected)
dbussourcewheezy1.6.8-1+deb7u1lowDSA-2707-1

Notes

[squeeze] - dbus <not-affected> (Introduced in 1.4.16)

Search for package or bug name: Reporting problems