CVE-2013-2172

NameCVE-2013-2172
Descriptionjcp/xml/dsig/internal/dom/DOMCanonicalizationMethod.java in Apache Santuario XML Security for Java 1.4.x before 1.4.8 and 1.5.x before 1.5.5 allows context-dependent attackers to spoof an XML Signature by using the CanonicalizationMethod parameter to specify an arbitrary weak "canonicalization algorithm to apply to the SignedInfo part of the Signature."
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-85-1, DSA-3065-1
NVD severitymedium
Debian Bugs720375

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libxml-security-java (PTS)stretch1.5.8-2fixed
stretch (security)1.5.8-2+deb9u1fixed
buster, bullseye2.0.10-2fixed
buster (security)2.0.10-2+deb10u1fixed
bullseye (security)2.0.10-2+deb11u1fixed
bookworm, sid2.1.7-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libxml-security-javasourcesqueeze1.4.3-2+deb6u1DLA-85-1
libxml-security-javasourcewheezy1.4.5-1+deb7u1DSA-3065-1
libxml-security-javasource(unstable)1.5.5-2720375

Notes

http://santuario.apache.org/secadv.data/CVE-2013-2172.txt.asc

Search for package or bug name: Reporting problems