CVE-2013-2174

NameCVE-2013-2174
DescriptionHeap-based buffer overflow in the curl_easy_unescape function in lib/escape.c in cURL and libcurl 7.7 through 7.30.0 allows remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a crafted string ending in a "%" (percent) character.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2713-1
NVD severitymedium (attack range: remote)
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
curl (PTS)squeeze (security), squeeze7.21.0-2.1+squeeze8fixed
squeeze (lts)7.21.0-2.1+squeeze11fixed
wheezy7.26.0-1+wheezy11fixed
wheezy (security)7.26.0-1+wheezy12fixed
jessie, sid7.38.0-4fixed

The information above is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
curlsource(unstable)7.31.0-1medium
curlsourcesqueeze7.21.0-2.1+squeeze4mediumDSA-2713-1
curlsourcewheezy7.26.0-1+wheezy3mediumDSA-2713-1

Search for package or bug name: Reporting problems