CVE-2013-2210

NameCVE-2013-2210
DescriptionHeap-based buffer overflow in the XML Signature Reference functionality in Apache Santuario XML Security for C++ (aka xml-security-c) before 1.7.2 allows context-dependent attackers to cause a denial of service (crash) and possibly execute arbitrary code via malformed XPointer expressions. NOTE: this is due to an incorrect fix for CVE-2013-2154.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2717-1
NVD severityhigh (attack range: remote)
Debian Bugs714241
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
xml-security-c (PTS)squeeze, squeeze (security)1.5.1-3+squeeze3fixed
wheezy (security), wheezy1.6.1-5+deb7u2fixed
stretch, jessie1.7.2-3fixed
sid1.7.2-3.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
xml-security-csource(unstable)1.6.1-7high714241
xml-security-csourcesqueeze1.5.1-3+squeeze3highDSA-2717-1
xml-security-csourcewheezy1.6.1-5+deb7u2highDSA-2717-1

Notes

http://santuario.apache.org/secadv.data/CVE-2013-2210.txt

Search for package or bug name: Reporting problems