CVE-2013-2220

NameCVE-2013-2220
DescriptionBuffer overflow in the radius_get_vendor_attr function in the Radius extension before 1.2.7 for PHP allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a large Vendor Specific Attributes (VSA) length value.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2726-1
NVD severityhigh (attack range: remote)
Debian Bugs714362
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
php-radius (PTS)squeeze, squeeze (security)1.2.5-2+squeeze1fixed
wheezy, wheezy (security)1.2.5-2.3+deb7u1fixed
jessie1.2.5-2.4fixed
stretch, sid1.2.7-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
php-radiussource(unstable)1.2.5-2.4high714362
php-radiussourcesqueeze1.2.5-2+squeeze1highDSA-2726-1
php-radiussourcewheezy1.2.5-2.3+deb7u1highDSA-2726-1

Notes

http://www.openwall.com/lists/oss-security/2013/06/28/2

Search for package or bug name: Reporting problems