CVE-2013-2236

NameCVE-2013-2236
DescriptionStack-based buffer overflow in the new_msg_lsa_change_notify function in the OSPFD API (ospf_api.c) in Quagga before 0.99.22.2, when --enable-opaque-lsa and the -a command line option are used, allows remote attackers to cause a denial of service (crash) via a large LSA.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2803-1
NVD severitylow (attack range: remote)
Debian Bugs726724

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
quagga (PTS)wheezy (security), wheezy0.99.22.4-1+wheezy2fixed
jessie (security), jessie0.99.23.1-1+deb8u1fixed
stretch, sid1.0.20160315-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
quaggasource(unstable)0.99.22.4-1low726724
quaggasourcesqueeze0.99.20.1-0+squeeze5lowDSA-2803-1
quaggasourcewheezy0.99.22.4-1+wheezy1lowDSA-2803-1

Notes

http://lists.quagga.net/pipermail/quagga-dev/2013-July/010621.html

Search for package or bug name: Reporting problems