CVE-2013-2458

NameCVE-2013-2458
DescriptionUnspecified vulnerability in the Java Runtime Environment (JRE) component in Oracle Java SE 7 Update 21 and earlier, and OpenJDK 7, allows remote attackers to affect confidentiality and integrity via unknown vectors related to Libraries. NOTE: the previous information is from the June 2013 CPU. Oracle has not commented on claims from another vendor that this issue allows remote attackers to bypass the Java sandbox via "an error related to method handles."
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2722-1
NVD severitymedium (attack range: remote)
Debian/oldoldstablenot vulnerable.
Debian/oldstablepackage openjdk-7 is vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
openjdk-6 (PTS)squeeze6b18-1.8.13-0+squeeze2fixed
squeeze (security)6b31-1.13.3-1~deb6u1fixed
squeeze (lts)6b35-1.13.7-1~deb6u1fixed
wheezy6b27-1.12.5-1fixed
wheezy (security)6b35-1.13.7-1~deb7u1fixed
sid6b35-1.13.7-1fixed
openjdk-7 (PTS)wheezy7u3-2.1.7-1vulnerable
wheezy (security)7u79-2.5.6-1~deb7u1fixed
stretch, jessie7u75-2.5.4-2fixed
jessie (security)7u79-2.5.6-1~deb8u1fixed
sid7u79-2.5.6-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
openjdk-6source(unstable)(not affected)
openjdk-7source(unstable)7u25-2.3.10-1medium
openjdk-7sourcewheezy7u25-2.3.10-1~deb7u1mediumDSA-2722-1

Notes

- openjdk-6 <not-affected> (Only affects Java 7)

Search for package or bug name: Reporting problems