CVE-2013-2488

NameCVE-2013-2488
DescriptionThe DTLS dissector in Wireshark 1.6.x before 1.6.14 and 1.8.x before 1.8.6 does not validate the fragment offset before invoking the reassembly state machine, which allows remote attackers to cause a denial of service (application crash) via a large offset value that triggers write access to an invalid memory location.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, web search, more)
ReferencesDSA-2644-1
NVD severitymedium (attack range: remote)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wireshark (PTS)squeeze, squeeze (security)1.2.11-6+squeeze14fixed
squeeze (lts)1.8.2-5wheezy16~deb6u1fixed
wheezy (security), wheezy1.8.2-5wheezy16fixed
jessie (security), jessie1.12.1+g01b65bf-4+deb8u3fixed
stretch, sid2.0.1+g59ea380-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wiresharksource(unstable)1.8.2-5medium
wiresharksourcesqueeze1.2.11-6+squeeze10mediumDSA-2644-1
wiresharksourcewheezy1.8.2-5wheezy1medium

Notes

http://www.wireshark.org/security/wnpa-sec-2013-22.html
https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=8380
Versions affected: 1.8.0 to 1.8.X, 1.6.0 to 1.6.X

Search for package or bug name: Reporting problems