CVE-2013-2776

NameCVE-2013-2776
Descriptionsudo 1.3.5 through 1.7.10p5 and 1.8.0 through 1.8.6p6, when running on systems without /proc or the sysctl function with the tty_tickets option enabled, does not properly validate the controlling terminal device, which allows local users with sudo permissions to hijack the authorization of another terminal via vectors related to connecting to the standard input, output, and error file descriptors of another terminal. NOTE: this is one of three closely-related vulnerabilities that were originally assigned CVE-2013-1776, but they have been SPLIT because of different affected versions.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2642-1
NVD severitymedium (attack range: local)
Debian Bugs701839
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
sudo (PTS)squeeze (security), squeeze1.7.4p4-2.squeeze.4fixed
squeeze (lts)1.7.4p4-2.squeeze.5fixed
wheezy1.8.5p2-1+nmu1fixed
wheezy (security)1.8.5p2-1+nmu2fixed
jessie1.8.10p3-1+deb8u1fixed
sid1.8.12-1fixed

The information above is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
sudosource(unstable)1.8.5p2-1+nmu1medium701839
sudosourcesqueeze1.7.4p4-2.squeeze.4mediumDSA-2642-1

Search for package or bug name: Reporting problems