CVE-2013-2877

NameCVE-2013-2877
Descriptionparser.c in libxml2 before 2.9.0, as used in Google Chrome before 28.0.1500.71 and other products, allows remote attackers to cause a denial of service (out-of-bounds read) via a document that ends abruptly, related to the lack of certain checks for the XML_PARSER_EOF state.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2724-1, DSA-2779-1
NVD severitymedium (attack range: remote)
Debian Bugs715531
Debian/oldoldstablepackage chromium-browser is vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
chromium-browser (PTS)squeeze, squeeze (security)6.0.472.63~r59945-5+squeeze6vulnerable
wheezy, wheezy (security)37.0.2062.120-1~deb7u1fixed
jessie41.0.2272.118-1fixed
jessie (security)43.0.2357.65-1~deb8u1fixed
stretch42.0.2311.135-2fixed
sid43.0.2357.65-1fixed
libxml2 (PTS)squeeze, squeeze (security)2.7.8.dfsg-2+squeeze8fixed
squeeze (lts)2.7.8.dfsg-2+squeeze11fixed
wheezy2.8.0+dfsg1-7+wheezy2fixed
wheezy (security)2.8.0+dfsg1-7+wheezy4fixed
stretch, jessie2.9.1+dfsg1-5fixed
sid2.9.2+dfsg1-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
chromium-browsersource(unstable)28.0.1500.71-1medium
chromium-browsersourcesqueeze(unfixed)end-of-life
chromium-browsersourcewheezy28.0.1500.71-1~deb7u1mediumDSA-2724-1
libxml2source(unstable)2.9.1+dfsg1-1medium715531
libxml2sourcesqueeze2.7.8.dfsg-2+squeeze8mediumDSA-2779-1
libxml2sourcewheezy2.8.0+dfsg1-7+nmu2mediumDSA-2779-1

Search for package or bug name: Reporting problems