CVE-2013-2902

NameCVE-2013-2902
DescriptionUse-after-free vulnerability in the XSLT ProcessingInstruction implementation in Blink, as used in Google Chrome before 29.0.1547.57, allows remote attackers to cause a denial of service or possibly have unspecified other impact via vectors related to an applyXSLTransform call involving (1) an HTML document or (2) an xsl:processing-instruction element that is still in the process of loading.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2741-1
NVD severityhigh (attack range: remote)
Debian/oldstablepackage chromium-browser is vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
chromium-browser (PTS)squeeze (security), squeeze6.0.472.63~r59945-5+squeeze6vulnerable
wheezy, wheezy (security)37.0.2062.120-1~deb7u1fixed
jessie41.0.2272.118-1fixed
sid42.0.2311.90-1fixed
libxslt (PTS)squeeze (security), squeeze1.1.26-6+squeeze3fixed
wheezy1.1.26-14.1fixed
sid, jessie1.1.28-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
chromium-browsersource(unstable)29.0.1547.57-1high
chromium-browsersourcesqueeze(unfixed)end-of-life
chromium-browsersourcewheezy29.0.1547.57-1~deb7u1highDSA-2741-1
libxsltsource(unstable)(not affected)

Notes

- libxslt <not-affected> (according to https://chromiumcodereview.appspot.com/20856002 this is an issue on chromium's side of xslt handling)

Search for package or bug name: Reporting problems