CVE-2013-3557

NameCVE-2013-3557
DescriptionThe dissect_ber_choice function in epan/dissectors/packet-ber.c in the ASN.1 BER dissector in Wireshark 1.6.x before 1.6.15 and 1.8.x before 1.8.7 does not properly initialize a certain variable, which allows remote attackers to cause a denial of service (application crash) via a malformed packet.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2700-1
NVD severitymedium (attack range: remote)
Debian Bugs709167
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wireshark (PTS)squeeze, squeeze (security)1.2.11-6+squeeze14fixed
squeeze (lts)1.8.2-5wheezy15~deb6u1fixed
wheezy1.8.2-5wheezy12fixed
wheezy (security)1.8.2-5wheezy15fixed
jessie1.12.1+g01b65bf-4fixed
stretch, sid1.12.5+g5819e5b-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wiresharksource(unstable)1.8.7-1unimportant709167
wiresharksourcesqueeze1.2.11-6+squeeze11medium
wiresharksourcewheezy1.8.2-5wheezy3mediumDSA-2700-1

Notes

Not suitable for code injection

Search for package or bug name: Reporting problems