CVE-2013-3560

NameCVE-2013-3560
DescriptionThe dissect_dsmcc_un_download function in epan/dissectors/packet-mpeg-dsmcc.c in the MPEG DSM-CC dissector in Wireshark 1.8.x before 1.8.7 uses an incorrect format string, which allows remote attackers to cause a denial of service (application crash) via a malformed packet.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2700-1
NVD severitymedium (attack range: remote)
Debian Bugs709167
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wireshark (PTS)squeeze (security), squeeze1.2.11-6+squeeze14fixed
squeeze (lts)1.2.11-6+squeeze15fixed
wheezy1.8.2-5wheezy12fixed
wheezy (security)1.8.2-5wheezy14fixed
jessie, sid1.12.1+g01b65bf-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wiresharksource(unstable)1.8.7-1unimportant709167
wiresharksourcesqueeze(not affected)
wiresharksourcewheezy1.8.2-5wheezy3mediumDSA-2700-1

Notes

[squeeze] - wireshark <not-affected> (Only affects 1.8.x)
http://www.wireshark.org/security/wnpa-sec-2013-28.html
Not suitable for code injection

Search for package or bug name: Reporting problems