CVE-2013-3571

NameCVE-2013-3571
Descriptionsocat 1.2.0.0 before 1.7.2.2 and 2.0.0-b1 before 2.0.0-b6, when used for a listen type address and the fork option is enabled, allows remote attackers to cause a denial of service (file descriptor consumption) via multiple request that are refused based on the (1) sourceport, (2) lowport, (3) range, or (4) tcpwrap restrictions.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitylow
Debian Bugs709931

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
socat (PTS)jessie1.7.2.4-2fixed
stretch1.7.3.1-2+deb9u1fixed
buster1.7.3.2-2fixed
bullseye, sid1.7.3.4-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
socatsource(unstable)1.7.1.3-1.5low709931

Notes

[squeeze] - socat <no-dsa> (Minor issue)
[wheezy] - socat <no-dsa> (Minor issue)
http://www.dest-unreach.org/socat/contrib/socat-secadv4.html

Search for package or bug name: Reporting problems