CVE-2013-4073

NameCVE-2013-4073
DescriptionThe OpenSSL::SSL.verify_certificate_identity function in lib/openssl/ssl.rb in Ruby 1.8 before 1.8.7-p374, 1.9 before 1.9.3-p448, and 2.0 before 2.0.0-p247 does not properly handle a '\0' character in a domain name in the Subject Alternative Name field of an X.509 certificate, which allows man-in-the-middle attackers to spoof arbitrary SSL servers via a crafted certificate issued by a legitimate Certification Authority, a related issue to CVE-2009-2408.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2738-1, DSA-2809-1
NVD severitymedium (attack range: remote)
Debian Bugs714541, 714543
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
puppet (PTS)squeeze (security), squeeze2.6.2-5+squeeze9fixed
squeeze (lts)2.6.2-5+squeeze10fixed
wheezy, wheezy (security)2.7.23-1~deb7u3fixed
jessie, sid3.7.2-2fixed
ruby1.8 (PTS)squeeze (security), squeeze1.8.7.302-2squeeze2fixed
squeeze (lts)1.8.7.302-2squeeze3fixed
wheezy1.8.7.358-7.1+deb7u1fixed
wheezy (security)1.8.7.358-7.1+deb7u2fixed
ruby1.9.1 (PTS)squeeze (security), squeeze1.9.2.0-2+deb6u2fixed
wheezy1.9.3.194-8.1+deb7u2fixed
wheezy (security)1.9.3.194-8.1+deb7u3fixed

The information above is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
puppetsource(unstable)(not affected)
ruby1.8source(unstable)1.8.7.358-7.1medium714541
ruby1.8sourcesqueeze1.8.7.302-2squeeze2mediumDSA-2809-1
ruby1.8sourcewheezy1.8.7.358-7.1+deb7u1mediumDSA-2809-1
ruby1.9.1source(unstable)1.9.3.194-8.2medium714543
ruby1.9.1sourcesqueeze1.9.2.0-2+deb6u1mediumDSA-2738-1
ruby1.9.1sourcewheezy1.9.3.194-8.1+deb7u1mediumDSA-2738-1

Notes

- puppet <not-affected> (Only affects Puppet Enterprise)
http://www.ruby-lang.org/en/news/2013/06/27/hostname-check-bypassing-vulnerability-in-openssl-client-cve-2013-4073/
https://github.com/ruby/ruby/commit/2669b84d407ab431e965145c827db66c91158f89 (1.9.3)
https://github.com/ruby/ruby/commit/961bf7496ded3acfe847cf56fa90bbdcfd6e614f (1.8.7)
Regression with patch: https://bugs.ruby-lang.org/issues/8575
http://svn.ruby-lang.org/cgi-bin/viewvc.cgi?revision=41812&view=revision

Search for package or bug name: Reporting problems