CVE-2013-4074

NameCVE-2013-4074
DescriptionThe dissect_capwap_data function in epan/dissectors/packet-capwap.c in the CAPWAP dissector in Wireshark 1.6.x before 1.6.16 and 1.8.x before 1.8.8 incorrectly uses a -1 data value to represent an error condition, which allows remote attackers to cause a denial of service (application crash) via a crafted packet.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2709-1
NVD severitymedium (attack range: remote)
Debian Bugs711918
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wireshark (PTS)squeeze, squeeze (security)1.2.11-6+squeeze14fixed
squeeze (lts)1.8.2-5wheezy16~deb6u1fixed
wheezy1.8.2-5wheezy12fixed
wheezy (security)1.8.2-5wheezy16fixed
jessie1.12.1+g01b65bf-4fixed
jessie (security)1.12.1+g01b65bf-4+deb8u2fixed
stretch, sid1.12.6+gee1fce6-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wiresharksource(unstable)1.10.0-1medium711918
wiresharksourcesqueeze(not affected)
wiresharksourcewheezy1.8.2-5wheezy4mediumDSA-2709-1

Notes

[squeeze] - wireshark <not-affected> (Vulnerable code not present)
https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=8725

Search for package or bug name: Reporting problems