CVE-2013-4078

NameCVE-2013-4078
Descriptionepan/dissectors/packet-rdp.c in the RDP dissector in Wireshark 1.8.x before 1.8.8 does not validate return values during checks for data availability, which allows remote attackers to cause a denial of service (application crash) via a crafted packet.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2709-1
NVD severitymedium (attack range: remote)
Debian Bugs711918
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wireshark (PTS)squeeze (security), squeeze1.2.11-6+squeeze14fixed
squeeze (lts)1.2.11-6+squeeze15fixed
wheezy1.8.2-5wheezy12fixed
wheezy (security)1.8.2-5wheezy14fixed
jessie, sid1.12.1+g01b65bf-3fixed

The information above is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wiresharksource(unstable)1.10.0-1medium711918
wiresharksourcesqueeze(not affected)
wiresharksourcewheezy1.8.2-5wheezy4mediumDSA-2709-1

Notes

[squeeze] - wireshark <not-affected> (Only affects 1.8+)
https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=7862
https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=8729

Search for package or bug name: Reporting problems