CVE-2013-4081

NameCVE-2013-4081
DescriptionThe http_payload_subdissector function in epan/dissectors/packet-http.c in the HTTP dissector in Wireshark 1.6.x before 1.6.16 and 1.8.x before 1.8.8 does not properly determine when to use a recursive approach, which allows remote attackers to cause a denial of service (stack consumption) via a crafted packet.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2709-1
NVD severitymedium (attack range: remote)
Debian Bugs711918
Debian/oldstablepackage wireshark is vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wireshark (PTS)squeeze (security), squeeze1.2.11-6+squeeze14vulnerable
squeeze (lts)1.8.2-5wheezy15~deb6u1vulnerable
wheezy1.8.2-5wheezy12fixed
wheezy (security)1.8.2-5wheezy15fixed
jessie, sid1.12.1+g01b65bf-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wiresharksource(unstable)1.10.0-1unimportant711918
wiresharksourcewheezy1.8.2-5wheezy4mediumDSA-2709-1

Notes

https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=8733
Not suitable for code injection

Search for package or bug name: Reporting problems