CVE-2013-4083

NameCVE-2013-4083
DescriptionThe dissect_pft function in epan/dissectors/packet-dcp-etsi.c in the DCP ETSI dissector in Wireshark 1.6.x before 1.6.16, 1.8.x before 1.8.8, and 1.10.0 does not validate a certain fragment length value, which allows remote attackers to cause a denial of service (application crash) via a crafted packet.
SourceCVE (at NVD; LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2709-1
NVD severitymedium (attack range: remote)
Debian Bugs711918

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wireshark (PTS)wheezy (security), wheezy1.8.2-5wheezy18fixed
jessie1.12.1+g01b65bf-4+deb8u5fixed
jessie (security)1.12.1+g01b65bf-4+deb8u6fixed
stretch, sid2.0.3+geed34f0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wiresharksource(unstable)1.10.0-1medium711918
wiresharksourcesqueeze1.2.11-6+squeeze11medium
wiresharksourcewheezy1.8.2-5wheezy4mediumDSA-2709-1

Notes

https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=8717

Search for package or bug name: Reporting problems