DescriptionCyrus SASL 2.1.23, 2.1.26, and earlier does not properly handle when a ...
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
Debian Bugs716835, 784112

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
cyrus-sasl2 (PTS)stretch (security), stretch2.1.27~101-g0780600+dfsg-3+deb9u1fixed
buster, buster (security)2.1.27+dfsg-1+deb10u1fixed
bullseye, sid2.1.27+dfsg-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
cyrus-sasl2source(unstable)2.1.26.dfsg1-14716835, 784112
cyrus-sasl2sourcesqueeze(not affected)
cyrus-sasl2sourcewheezy(not affected)


[wheezy] - cyrus-sasl2 <not-affected> (Only exploitable with eglibc 2.17 and later)
[squeeze] - cyrus-sasl2 <not-affected> (Only exploitable with eglibc 2.17 and later)
Was originally already fixed in 2.1.25.dfsg1-14 (cf. #716835)

Search for package or bug name: Reporting problems