CVE-2013-4155

NameCVE-2013-4155
DescriptionOpenStack Swift before 1.9.1 in Folsom, Grizzly, and Havana allows authenticated users to cause a denial of service ("superfluous" tombstone consumption and Swift cluster slowdown) via a DELETE request with a timestamp that is older than expected.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDSA-2737-1
Debian Bugs719008

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
swift (PTS)buster2.19.1-1fixed
buster (security)2.19.1-1+deb10u1fixed
bullseye (security), bullseye2.26.0-10+deb11u1fixed
bookworm2.30.0-4fixed
sid, trixie2.31.1-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
swiftsourcewheezy1.4.8-2+deb7u1DSA-2737-1
swiftsource(unstable)1.8.0-7719008

Search for package or bug name: Reporting problems