CVE-2013-4160

NameCVE-2013-4160
DescriptionLittle CMS (lcms2) before 2.5, as used in OpenJDK 7 and possibly other products, allows remote attackers to cause a denial of service (NULL pointer dereference and crash) via vectors related to (1) cmsStageAllocLabV2ToV4curves, (2) cmsPipelineDup, (3) cmsAllocProfileSequenceDescription, (4) CurvesAlloc, and (5) cmsnamed.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs714529, 728208

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
lcms2 (PTS)jessie2.6-3+deb8u1fixed
jessie (security)2.6-3+deb8u2fixed
stretch (security), stretch2.8-4+deb9u1fixed
bullseye, buster2.9-3fixed
sid2.9-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
lcmssource(unstable)1.19.dfsg1-1.3low728208
lcmssourcewheezy1.19.dfsg2-1.2+deb7u1
lcms2source(unstable)2.2+git20110628-2.3714529
lcms2sourcewheezy2.2+git20110628-2.2+deb7u1

Notes

[squeeze] - lcms <no-dsa> (Minor issue)
https://github.com/mm2/Little-CMS/commit/91c2db7f2559be504211b283bc3a2c631d6f06d9
https://bugzilla.suse.com/show_bug.cgi?id=826097#c9

Search for package or bug name: Reporting problems