CVE-2013-4164

NameCVE-2013-4164
DescriptionHeap-based buffer overflow in Ruby 1.8, 1.9 before 1.9.3-p484, 2.0 before 2.0.0-p353, 2.1 before 2.1.0 preview2, and trunk before revision 43780 allows context-dependent attackers to cause a denial of service (segmentation fault) and possibly execute arbitrary code via a string that is converted to a floating point value, as demonstrated using (1) the to_f method or (2) JSON.parse.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2809-1, DSA-2810-1
NVD severitymedium (attack range: remote)
Debian Bugs730178, 730189, 730190
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot known to be vulnerable.
Debian/unstablenot known to be vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ruby1.8 (PTS)squeeze (security), squeeze1.8.7.302-2squeeze2fixed
squeeze (lts)1.8.7.302-2squeeze3fixed
wheezy1.8.7.358-7.1+deb7u1fixed
wheezy (security)1.8.7.358-7.1+deb7u2fixed
ruby1.9.1 (PTS)squeeze (security), squeeze1.9.2.0-2+deb6u2fixed
squeeze (lts)1.9.2.0-2+deb6u3fixed
wheezy1.9.3.194-8.1+deb7u2fixed
wheezy (security)1.9.3.194-8.1+deb7u3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ruby1.8source(unstable)1.8.7.358-9medium730189
ruby1.8sourcesqueeze1.8.7.302-2squeeze2mediumDSA-2809-1
ruby1.8sourcewheezy1.8.7.358-7.1+deb7u1mediumDSA-2809-1
ruby1.9.1source(unstable)1.9.3.484-1medium730178
ruby1.9.1sourcesqueeze1.9.2.0-2+deb6u2mediumDSA-2810-1
ruby1.9.1sourcewheezy1.9.3.194-8.1+deb7u2mediumDSA-2810-1
ruby2.0source(unstable)2.0.0.353-1medium730190

Notes

https://www.ruby-lang.org/en/news/2013/11/22/heap-overflow-in-floating-point-parsing-cve-2013-4164/

Search for package or bug name: Reporting problems