CVE-2013-4237

NameCVE-2013-4237
Descriptionsysdeps/posix/readdir_r.c in the GNU C Library (aka glibc or libc6) 2.18 and earlier allows context-dependent attackers to cause a denial of service (out-of-bounds write and crash) or possibly execute arbitrary code via a crafted (1) NTFS or (2) CIFS image.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-165-1
NVD severitymedium
Debian Bugs719558

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
glibc (PTS)jessie (security), jessie2.19-18+deb8u10fixed
stretch2.24-11+deb9u4fixed
stretch (security)2.24-11+deb9u1fixed
buster2.28-10fixed
bullseye, sid2.29-10fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
eglibcsource(unstable)(unfixed)
eglibcsourcesqueeze2.11.3-4+deb6u5DLA-165-1
eglibcsourcewheezy2.13-38+deb7u1
glibcsource(unstable)2.17-94719558

Notes

http://sourceware.org/bugzilla/show_bug.cgi?id=14699
http://sourceware.org/ml/libc-alpha/2013-05/msg00445.html

Search for package or bug name: Reporting problems