CVE-2013-4244

NameCVE-2013-4244
DescriptionThe LZW decompressor in the gif2tiff tool in libtiff 4.0.3 and earlier allows context-dependent attackers to cause a denial of service (out-of-bounds write and crash) or possibly execute arbitrary code via a crafted GIF image.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2744-1
NVD severitymedium (attack range: remote, user-initiated)
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
tiff (PTS)squeeze (security), squeeze3.9.4-5+squeeze10fixed
squeeze (lts)3.9.4-5+squeeze11fixed
wheezy, wheezy (security)4.0.2-6+deb7u3fixed
jessie, sid4.0.3-12.1fixed
tiff3 (PTS)wheezy3.9.6-11fixed

The information above is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
tiffsource(unstable)4.0.3-3medium
tiffsourcesqueeze3.9.4-5+squeeze10mediumDSA-2744-1
tiffsourcewheezy4.0.2-6+deb7u2mediumDSA-2744-1
tiff3source(unstable)(not affected)

Notes

- tiff3 <not-affected> (The tiff3 source package doesn't build the TIFF tools)

Search for package or bug name: Reporting problems