CVE-2013-4286

NameCVE-2013-4286
DescriptionApache Tomcat before 6.0.39, 7.x before 7.0.47, and 8.x before 8.0.0-RC3, when an HTTP connector or AJP connector is used, does not properly handle certain inconsistent HTTP request headers, which allows remote attackers to trigger incorrect identification of a request's length and conduct request-smuggling attacks via (1) multiple Content-Length headers or (2) a Content-Length header and a "Transfer-Encoding: chunked" header. NOTE: this vulnerability exists because of an incomplete fix for CVE-2005-2090.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDLA-91-1, DSA-2897-1
NVD severitymedium (attack range: remote)
Debian/oldoldstablepackage tomcat6 is vulnerable.
Debian/oldstablepackage tomcat6 is vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
tomcat6 (PTS)squeeze, squeeze (security)6.0.35-1+squeeze4vulnerable
squeeze (lts)6.0.41-2+squeeze6fixed
wheezy, wheezy (security)6.0.35-6+deb7u1vulnerable
stretch, sid, jessie6.0.41-3fixed
tomcat7 (PTS)wheezy, wheezy (security)7.0.28-4+deb7u1fixed
stretch, sid, jessie7.0.56-3fixed
tomcat8 (PTS)stretch, sid, jessie8.0.14-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
tomcat6source(unstable)6.0.39medium
tomcat6sourcesqueeze6.0.41-2+squeeze5mediumDLA-91-1
tomcat7source(unstable)7.0.47medium
tomcat7sourcewheezy7.0.28-4+deb7u1mediumDSA-2897-1
tomcat8source(unstable)8.0.0medium

Search for package or bug name: Reporting problems