CVE-2013-4303

NameCVE-2013-4303
Descriptionincludes/libs/IEUrlExtension.php in the MediaWiki API in MediaWiki 1.19.x before 1.19.8, 1.20.x before 1.20.7, and 1.21.x before 1.21.2 does not properly detect extensions when there are an even number of "." (period) characters in a string, which allows remote attackers to conduct cross-site scripting (XSS) attacks via the siprop parameter in a query action to wiki/api.php.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mediawiki (PTS)stretch1:1.27.7-1~deb9u1fixed
stretch (security)1:1.27.7-1~deb9u2fixed
buster, buster (security)1:1.31.4-1~deb10u1fixed
bullseye, sid1:1.31.5-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mediawikisource(unstable)1:1.19.8+dfsg-1unimportant
mediawikisourcesqueeze(unfixed)end-of-life

Notes

https://bugzilla.wikimedia.org/show_bug.cgi?id=52746
IE6 lacks so many security features that this doesn't matter

Search for package or bug name: Reporting problems