CVE-2013-4315

NameCVE-2013-4315
DescriptionDirectory traversal vulnerability in Django 1.4.x before 1.4.7, 1.5.x before 1.5.3, and 1.6.x before 1.6 beta 3 allows remote attackers to read arbitrary files via a file path in the ALLOWED_INCLUDE_ROOTS setting followed by a .. (dot dot) in a ssi template tag.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2755-1
NVD severitymedium (attack range: remote)
Debian Bugs722605
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
python-django (PTS)squeeze (security), squeeze1.2.3-3+squeeze10fixed
squeeze (lts)1.2.3-3+squeeze12fixed
wheezy1.4.5-1+deb7u8fixed
wheezy (security)1.4.5-1+deb7u11fixed
jessie, sid1.7.7-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
python-djangosource(unstable)1.5.3-1medium722605
python-djangosourcesqueeze1.2.3-3+squeeze7mediumDSA-2755-1
python-djangosourcewheezy1.4.5-1+deb7u3mediumDSA-2755-1

Search for package or bug name: Reporting problems