CVE-2013-4322

NameCVE-2013-4322
DescriptionApache Tomcat before 6.0.39, 7.x before 7.0.50, and 8.x before 8.0.0-RC10 processes chunked transfer coding without properly handling (1) a large total amount of chunked data or (2) whitespace characters in an HTTP header value within a trailer field, which allows remote attackers to cause a denial of service by streaming data. NOTE: this vulnerability exists because of an incomplete fix for CVE-2012-3544.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDLA-91-1, DSA-2897-1
NVD severitymedium (attack range: remote)
Debian/oldoldstablepackage tomcat6 is vulnerable.
Debian/oldstablepackage tomcat6 is vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
tomcat6 (PTS)squeeze, squeeze (security)6.0.35-1+squeeze4vulnerable
squeeze (lts)6.0.41-2+squeeze7fixed
wheezy, wheezy (security)6.0.35-6+deb7u1vulnerable
jessie6.0.41-3fixed
stretch, sid6.0.41-4fixed
tomcat7 (PTS)wheezy, wheezy (security)7.0.28-4+deb7u1fixed
jessie7.0.56-3fixed
stretch, sid7.0.62-1fixed
tomcat8 (PTS)jessie8.0.14-1fixed
stretch, sid8.0.23-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
tomcat6source(unstable)6.0.39medium
tomcat6sourcesqueeze6.0.41-2+squeeze5mediumDLA-91-1
tomcat7source(unstable)7.0.50medium
tomcat7sourcewheezy7.0.28-4+deb7u1mediumDSA-2897-1
tomcat8source(unstable)8.0.0medium

Search for package or bug name: Reporting problems