CVE-2013-4388

NameCVE-2013-4388
DescriptionBuffer overflow in the mp4a packetizer (modules/packetizer/mpeg4audio.c) in VideoLAN VLC Media Player before 2.0.8 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via unspecified vectors.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2973-1
NVD severitymedium (attack range: remote)
Debian Bugs726528

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
vlc (PTS)wheezy, wheezy (security)2.0.3-5+deb7u2fixed
jessie2.2.6-1~deb8u1fixed
jessie (security)2.2.7-1~deb8u1fixed
stretch2.2.6-1~deb9u1fixed
stretch (security)2.2.7-1~deb9u1fixed
buster2.2.7-1fixed
sid2.2.8-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
vlcsource(unstable)2.1.0-1medium726528
vlcsourcesqueeze(unfixed)end-of-life
vlcsourcewheezy2.0.3-5+deb7u1mediumDSA-2973-1

Notes

[squeeze] - vlc <end-of-life> (Unsupported in squeeze-lts)
http://git.videolan.org/?p=vlc.git;a=commitdiff;h=9794ec1cd268c04c8bca13a5fae15df6594dff3e

Search for package or bug name: Reporting problems