CVE-2013-4389

NameCVE-2013-4389
DescriptionMultiple format string vulnerabilities in log_subscriber.rb files in the log subscriber component in Action Mailer in Ruby on Rails 3.x before 3.2.15 allow remote attackers to cause a denial of service via a crafted e-mail address that is improperly handled during construction of a log message.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2887-1, DSA-2888-1
NVD severitymedium (attack range: remote)
Debian Bugs726576
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
rails (PTS)squeeze, squeeze (security)2.3.5-1.2+squeeze8fixed
wheezy2:2.3.14.2fixed
jessie2:4.1.8-1fixed
stretch, sid2:4.1.10-1fixed
ruby-actionmailer-2.3 (PTS)wheezy2.3.14-3fixed
ruby-actionmailer-3.2 (PTS)wheezy (security), wheezy3.2.6-2+deb7u1fixed
ruby-actionpack-3.2 (PTS)wheezy (security), wheezy3.2.6-6+deb7u2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
railssource(unstable)(not affected)
rails-4.0source(unstable)(not affected)
ruby-actionmailer-2.3source(unstable)(not affected)
ruby-actionmailer-3.2source(unstable)3.2.16-1medium726576
ruby-actionmailer-3.2sourcewheezy3.2.6-2+deb7u1mediumDSA-2887-1
ruby-actionpack-3.2sourcewheezy3.2.6-6+deb7u1mediumDSA-2888-1

Notes

- rails-4.0 <not-affected> (Only affects 3.x)
- ruby-actionmailer-2.3 <not-affected> (Only affects 3.x)
- rails <not-affected> (Only affects 3.x)
Starting with 2.3.14.1 rails is a transition package

Search for package or bug name: Reporting problems