CVE-2013-4397

NameCVE-2013-4397
DescriptionMultiple integer overflows in the th_read function in lib/block.c in libtar before 1.2.20 allow remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a long (1) name or (2) link in an archive, which triggers a heap-based buffer overflow.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2817-1
NVD severitymedium (attack range: remote, user-initiated)
Debian Bugs725938
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libtar (PTS)squeeze (security), squeeze1.2.11-6+deb6u2fixed
wheezy, wheezy (security)1.2.16-1+deb7u2fixed
jessie, sid1.2.20-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libtarsource(unstable)1.2.20-1medium725938
libtarsourcesqueeze1.2.11-6+deb6u1mediumDSA-2817-1
libtarsourcewheezy1.2.16-1+deb7u1mediumDSA-2817-1

Search for package or bug name: Reporting problems