CVE-2013-4420

NameCVE-2013-4420
DescriptionMultiple directory traversal vulnerabilities in the (1) tar_extract_glob and (2) tar_extract_all functions in libtar 1.2.20 and earlier allow remote attackers to overwrite arbitrary files via a .. (dot dot) in a crafted tar file.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2863-1
NVD severitymedium (attack range: remote)
Debian Bugs731860
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libtar (PTS)squeeze, squeeze (security)1.2.11-6+deb6u2fixed
wheezy, wheezy (security)1.2.16-1+deb7u2fixed
stretch, sid, jessie1.2.20-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libtarsource(unstable)1.2.20-2medium731860
libtarsourcesqueeze1.2.11-6+deb6u2mediumDSA-2863-1
libtarsourcewheezy1.2.16-1+deb7u2mediumDSA-2863-1

Search for package or bug name: Reporting problems