DescriptionSQL injection vulnerability in Quassel IRC before 0.9.1, when Qt 4.8.5 or later and PostgreSQL 8.2 or later are used, allows remote attackers to execute arbitrary SQL commands via a \ (backslash) in a message.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
quassel (PTS)wheezy, wheezy (security)0.8.0-1+deb7u3vulnerable
jessie (security)1:0.10.0-2.3+deb8u1fixed
buster, sid1:0.12.4-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
quasselsourcesqueeze(not affected)


[wheezy] - quassel <no-dsa> (Issue only relevant if the Qt 4.8.5 fix would be backported)
[squeeze] - quassel <not-affected> (qt4-x11 is too old)
Issue when used with Qt >= 4.8.5 and PostgreSQL >= 8.2
Caused by a change in Qt's postgres driver:

Search for package or bug name: Reporting problems