CVE-2013-4451

NameCVE-2013-4451
Descriptiongitolite commit fa06a34 through 3.5.3 might allow attackers to have unspecified impact via vectors involving world-writable permissions when creating (1) ~/.gitolite.rc, (2) ~/.gitolite, or (3) ~/repositories/gitolite-admin.git on fresh installs.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gitolite3 (PTS)jessie3.6.1-2+deb8u2fixed
stretch3.6.6-1fixed
bullseye, sid, buster3.6.11-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gitolitesource(unstable)(not affected)
gitolite3source(unstable)(not affected)

Notes

- gitolite <not-affected> (vulnerable code introduced for v3.5.3)
- gitolite3 <not-affected> (vulnerable code introduced for v3.5.3)

Search for package or bug name: Reporting problems