CVE-2013-4471

NameCVE-2013-4471
DescriptionThe Identity v3 API in OpenStack Dashboard (Horizon) before 2013.2 does not require the current password when changing passwords for user accounts, which makes it easier for remote attackers to change a user password by leveraging the authentication token for that user.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
horizon (PTS)stretch3:10.0.1-1fixed
buster, buster (security)3:14.0.2-3+deb10u2fixed
bookworm, bullseye3:18.6.2-5fixed
sid3:19.2.0-6fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
horizonsourcewheezy(not affected)
horizonsource(unstable)2013.2-1

Notes

[wheezy] - horizon <not-affected> (v3 API introduced in Grizzly)
https://bugs.launchpad.net/horizon/+bug/1237989

Search for package or bug name: Reporting problems