CVE-2013-4473

NameCVE-2013-4473
DescriptionStack-based buffer overflow in the extractPages function in utils/pdfseparate.cc in poppler before 0.24.2 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a source filename.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1074-1
NVD severityhigh
Debian Bugs729064

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
poppler (PTS)jessie0.26.5-2+deb8u4fixed
jessie (security)0.26.5-2+deb8u13fixed
stretch (security), stretch0.48.0-2+deb9u2fixed
buster0.71.0-5fixed
bullseye, sid0.71.0-6fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
popplersource(unstable)0.18.4-9low729064
popplersourcesqueeze(not affected)
popplersourcewheezy0.18.4-6+deb7u2DLA-1074-1

Notes

[squeeze] - poppler <not-affected> (pdfseparate not yet present)

Search for package or bug name: Reporting problems