CVE-2013-4484

NameCVE-2013-4484
DescriptionVarnish before 3.0.5 allows remote attackers to cause a denial of service (child-process crash and temporary caching outage) via a GET request with trailing whitespace characters and no URI.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2814-1
NVD severitymedium (attack range: remote)
Debian Bugs728989
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
varnish (PTS)squeeze2.1.3-8+deb6u2fixed
squeeze (security)2.1.3-8+deb6u1fixed
wheezy (security), wheezy3.0.2-2+deb7u1fixed
jessie4.0.2-1fixed
stretch, sid4.0.3-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
varnishsource(unstable)3.0.5-1medium728989
varnishsourcesqueeze2.1.3-8+deb6u1mediumDSA-2814-1
varnishsourcewheezy3.0.2-2+deb7u1mediumDSA-2814-1

Notes

https://www.varnish-cache.org/trac/ticket/1367

Search for package or bug name: Reporting problems