DescriptionOff-by-one error in the dane_raw_tlsa in the DANE library (libdane) in GnuTLS 3.1.x before 3.1.16 and 3.2.x before 3.2.6 allows remote servers to cause a denial of service (memory corruption) via a response with more than four DANE entries. NOTE: this issue is due to an incomplete fix for CVE-2013-4466.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gnutls26 (PTS)wheezy, wheezy (security)2.12.20-8+deb7u5fixed
gnutls28 (PTS)jessie3.3.8-6+deb8u7fixed
jessie (security)3.3.8-6+deb8u6fixed
stretch (security)3.5.8-5+deb9u1fixed
buster, sid3.5.18-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gnutls26source(unstable)(not affected)
gnutls28source(unstable)(not affected)


- gnutls28 <not-affected> (libdane is not built; original patch for CVE-2013-4466 not applied)
- gnutls26 <not-affected> (only 3.1.x and 3.2.x)
off-by one issue in original fix for CVE-2013-4466

Search for package or bug name: Reporting problems