CVE-2013-4491

NameCVE-2013-4491
DescriptionCross-site scripting (XSS) vulnerability in actionpack/lib/action_view/helpers/translation_helper.rb in the internationalization component in Ruby on Rails 3.x before 3.2.16 and 4.x before 4.0.2 allows remote attackers to inject arbitrary web script or HTML via a crafted string that triggers generation of a fallback string by the i18n gem.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2888-1
NVD severitymedium (attack range: remote)
Debian Bugs731288, 731290

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
rails (PTS)wheezy2:2.3.14.2fixed
jessie (security), jessie2:4.1.8-1+deb8u4fixed
stretch, sid2:4.2.7.1-1fixed
ruby-actionpack-2.3 (PTS)wheezy2.3.14-5fixed
ruby-actionpack-3.2 (PTS)wheezy3.2.6-6+deb7u2fixed
wheezy (security)3.2.6-6+deb7u3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
railssource(unstable)(not affected)
rails-3.2source(unstable)3.2.16-3+0medium
rails-4.0source(unstable)4.0.2+dfsg-1medium731290
ruby-actionpack-2.3source(unstable)(not affected)
ruby-actionpack-3.2source(unstable)3.2.16-1medium731288
ruby-actionpack-3.2sourcewheezy3.2.6-6+deb7u1mediumDSA-2888-1

Notes

- ruby-actionpack-2.3 <not-affected> (vulnerable code not present)
- rails <not-affected> (Vulnerable code not present)
Starting with 2.3.14.1 rails is a transition package

Search for package or bug name: Reporting problems